Virtual ControlWave User Manual
Getting Additional Information

In addition to the information contained in this manual, you may receive additional assistance in using this product from the following sources:

Help Files / Release Notes

Many Bristol software products incorporate help screens. In addition, the software typically includes a ‘read me’ release notes file detailing new features in the product, as well as other information which was available too late for inclusion in the manual.

Contacting Bristol Directly

The address for our world headquarters is:

Bristol, Inc.
A division of Emerson Process Management
1100 Buckingham Street
Watertown, Connecticut 06795  USA

Our main phone numbers are:

(860) 945-2200
(860) 945-2213 (FAX)

Regular office hours are Monday through Friday, 8:00AM to 4:30PM Eastern Time, excluding holidays, and scheduled factory shutdowns. During other hours, callers may leave messages using Bristol's voice mail system.

Telephone / E-Mail Support - Technical Questions

During regular business hours, Bristol's Application Support Group can provide telephone/e-mail support for your technical questions.
Please refer to the table, below, for a list of products, and their associated technical support contact information:

<table>
<thead>
<tr>
<th>Product</th>
<th>Support Phone Number(s):</th>
<th>E-Mail Address:</th>
</tr>
</thead>
<tbody>
<tr>
<td>ControlWave series (hardware and software)</td>
<td>(860) 945-2394 (860) 945-2286</td>
<td><a href="mailto:bsupport@bristolbabcock.com">bsupport@bristolbabcock.com</a></td>
</tr>
<tr>
<td>Network 3000 hardware except for TeleFlow series</td>
<td>(860) 945-2502</td>
<td><a href="mailto:bsupport@bristolbabcock.com">bsupport@bristolbabcock.com</a></td>
</tr>
<tr>
<td>TeleFlow series (3530-xx)</td>
<td>(860) 945-8604.</td>
<td><a href="mailto:bsupport@bristolbabcock.com">bsupport@bristolbabcock.com</a></td>
</tr>
<tr>
<td>ACCOL, Open BSI, UOI, all other software except for ControlWave and OE.</td>
<td>(860) 945-2286</td>
<td><a href="mailto:bsupport@bristolbabcock.com">bsupport@bristolbabcock.com</a></td>
</tr>
<tr>
<td>OpenEnterprise (OE) software</td>
<td>(860) 945-3865</td>
<td><a href="mailto:scada@bristolbabcock.com">scada@bristolbabcock.com</a></td>
</tr>
<tr>
<td>Radio telemetry services (interfacing Bristol hardware to radios)</td>
<td>(407) 629-9463 (407) 629-9464.</td>
<td><a href="mailto:bsupport@bristolbabcock.com">bsupport@bristolbabcock.com</a></td>
</tr>
</tbody>
</table>

Non-Technical Questions, Product Orders, etc.

Questions of a non-technical nature (product orders, literature requests, price and delivery information, etc.) should be directed to the nearest Bristol sales office or to your Bristol-authorized sales representative. Please call the main Bristol number (860-945-2200) or visit our web site, listed below, if you are unsure which office covers your particular area.

Visit our Site on the World Wide Web

For general information about Bristol, Inc. and its products, please visit our site on the World Wide Web at: www.EmersonProcess.com/Bristol

Training Courses

Bristol's Training Department offers a wide variety of courses in Bristol hardware and software at our Watertown, Connecticut headquarters, and at selected Bristol regional offices, throughout the year. Contact our Training Department at (860) 945-2343 for course information, enrollment, pricing, and schedules.
Who Should Read This Document?

This document is intended to be read by a Programmer or System Engineer who will be configuring calculations that are to be stored in the OpenEnterprise Database.

This document assumes familiarity with the following subjects:

- ControlWave Designer
- OpenEnterprise Database Explorer / Database Object Viewer
# Table of Contents

What is the Virtual ControlWave? ........................................................................................................ 1
Before You Begin ..................................................................................................................................... 1
  Setting Up an IPC_40 Resource in your ControlWave Designer Project ........................................... 2
Using the Virtual ControlWave ............................................................................................................. 4
  A Simple Example - Using Virtual ControlWave to Perform a Calculation Using Flow Totals From Two Different RTUs ................................................................................................................. 4
Application Notes .................................................................................................................................. 12
  Including the Virtual ControlWave as part of your OpenEnterprise Session ................................. 12
  Using Lists in Your ControlWave Project to Improve Performance ............................................... 12
  Using the Same OE Database Signal as both an Input and an Output ........................................... 13
  Inputs and the OPC Quality Flag .................................................................................................... 14
  Limitations on the Number of Signals (Points) in the Virtual ControlWave Project ............... 14
Appendix A - Creating Local Signals in OpenEnterprise ................................................................. 15
Appendix B - Virtual ControlWave Configuration Text File (VCWCFG.PLC) ............................... 16
What is the Virtual ControlWave?

The Virtual ControlWave is essentially a ‘software’ version of the ControlWave controller that exists on your PC, instead of in a separate piece of hardware. It can do much of what a regular ControlWave can do, however, it has no I/O hardware, and like the ControlWave Designer I/O Simulator, it cannot store historical data (audit/archive) or run custom communication protocols. It can, however, communicate with the OpenEnterprise Database.

The Virtual ControlWave includes a set of tools that allow you to take real-time signals from the OpenEnterprise Database and bring them into a ControlWave Designer project. Once in ControlWave Designer, calculations can be created using those signals. The project may then be compiled and downloaded into the Virtual ControlWave, where it runs like any other project. The results of the calculations are then stored back in the OpenEnterprise Database.

This mechanism allows you to perform extensive calculations using any ACCOL III or IEC 61131 functions and function blocks. This can be used, for example, to do gas calculations, on data from multiple RTUs, which would have been beyond the scope of the OpenEnterprise Calculation Server.

There are three main parts to the Virtual ControlWave:

- Virtual ControlWave Configuration Tool – Allows you to identify which signals from the OE Database will be used in the Virtual ControlWave.

- Virtual Controlwave Statistics Tool – Displays current values of variables updated via the Virtual ControlWave.

- Virtual ControlWave – The actual soft-ControlWave.

Before You Begin

In order to use the Virtual ControlWave, you must have the following software installed and running:

- ControlWave Designer (Project used must include the IPC_40 resource)
- OpenEnterprise Server Version 2.53 Service Pack 1 (or newer). The OpenEnterprise Database must be configured and running. **NOTE: If you have Version 2.53 without Service Pack 1, you must manually start Polyhedra DDE software for the Virtual ControlWave Configuration Tool to function properly.**
- OpenEnterprise OPC Server must be running, if not running automatically.
- Virtual ControlWave Software, including configuration tools.
Setting Up an IPC_40 Resource in your ControlWave Designer Project

The Virtual ControlWave can only run in conjunction with a project that has an IPC_40 resource.

Setting Up an IPC_40 Resource for an All-New Project:

If you are creating an all-new ControlWave project, an IPC_40 resource is automatically added to your project by simply selecting the ‘ControlWave’ template. *(Don’t choose ‘CWMicro’ because it doesn’t use the IPC_40 resource.)*

Setting Up IPC_40 for an Existing Project:

If you have an existing ControlWave project that was NOT created with the IPC_40 resource, for example, it was created using the ‘CWMicro’ template, you can add an IPC_40 resource to the project in addition to the other resource you already have defined.

1. First, *right*-click on ‘Physical Hardware’, and choose **InsertÆConfiguration** from the pop-up menus.

2. In the Insert dialog box, enter a name for the configuration, then select ‘IPC_40’ for the “PLC type”, then click on **[OK]**.

3. Now, *right*-click on the icon that was just created, and choose **InsertÆResource** from the pop-up menu.
4. Next, enter a name for the resource, and choose ‘ControlWave’ as the “Processor type”. Click on [OK] when finished.

5. You should now create a task and program as you normally would. If you’re not sure how to do that, please see the manual *Getting Started with ControlWave Designer* (document# D5085).

6. It is important that you specify the correct settings for the resource, or the Virtual ControlWave will not function correctly. Right-click on the resource to bring up the Resource Settings dialog box.

- You must choose “DLL” for the port.
- The DLL must be ‘TCP/IP’.
- The IP address parameter must be set to ‘127.0.0.1’ because that address will maintain IP transmissions within the PC (which is where the Virtual ControlWave resides).

Click on [OK] when finished.
Using the Virtual ControlWave

A Simple Example - Using Virtual ControlWave to Perform a Calculation Using Flow Totals From Two Different RTUs.

Let’s say we have two RTUs called JOLIET_DRIVE and RIVER_ROAD that both feed data into the OE Database. Each has a flow meter, and we want to combine the flow meter readings from the two RTUs into a single value, representing the total flow. Here’s one way we could do it:

1. Start the SQL Client, and create a local signal in the OE Database that will be used to hold the result of the flow calculation, named TOTAL_FLOW. To do this, you need to run the following SQL statements in the SQL Client:

   ```sql
   insert into localrealanalog (name,regionname,devicename) values ('TOTAL_FLOW','','');
   commit;
   ```

   NOTE: For more information on local signals, see ‘Appendix A - Creating Local Signals’.

2. Start the OpenEnterprise Database Explorer, and call up the table or view that contains the data that will be used in your calculations. The data will appear within the Database Object Viewer. For this particular example, you would want the ‘Realanalog’ view, but any table can be used depending upon the needs of your calculation.

3. Start ControlWave Designer, and open the ControlWave Designer project in which you want to perform calculations.

4. Start the Virtual ControlWave Configuration Tool by clicking on Online → Virtual ControlWave Config, within ControlWave Designer.

5. If your project contains more than one resource, you will be prompted to select the configuration and resource that will be used by the Virtual ControlWave. This resource must use IPC_40.

6. Drag each object you want to use in your calculation (it could be a signal value, an inhibit status, etc.) from the Database Object Viewer into the Virtual ControlWave Configuration Tool window. In this case, those signals would be:
RIVER ROAD:@GV_.STATION_FLOW1

and

JOLIET DRIVE:@GV_.STATION_FLOW2

plus the TOTAL_FLOW signal we created in Step 1.

NOTE: This essentially copies an OPC Tag that will be used to establish a link between the OE Database, and your ControlWave project.

Once you have brought a particular object into the Virtual ControlWave Configuration Tool, you can optionally rename it. This might be necessary, for example, if you are collecting the same signal from multiple RTUs and you need to prevent duplicate names in your ControlWave project. To rename a signal, simply double-click on it and the Edit Variable dialog box will appear. The full OPC tag name is displayed in the window. Enter the new name in the “Variable Name” field. You can also specify whether the variable will serve as an input to function blocks/functions or as an output from them, by selecting either “Input” or “Output”. Click on [OK] when finished.

For our example, we have re-named RIVER ROAD:@GV_.STATION_FLOW1 to RR_FLOW1 and JOLIET DRIVE:@GV_.STATION_FLOW2 to JD_FLOW2. TOTAL_FLOW we named TOTAL_FLOW. You should also note that TOTAL_FLOW must be made an “Output” and the other two signals must be made “Inputs”.
Here is the full OPC tag from the OpenEnterprise Database.

If the variable serves as an input to functions and function blocks, choose “Input”. If it serves as an “Output” from them, choose “Output”.

You can enter a new name for the variable, here.

7. Once you have renamed the signals, and set their input/output type as desired, you can save them to your ControlWave project by clicking on File → Save in the Virtual ControlWave Configuration Tool. This will create a VCWAVE_VARIABLES group in the global variables worksheet of the currently open ControlWave project.

To access these new variables make sure you select the VCWAVE_VARIABLES section which is in the Global Variables worksheet under the resource you selected earlier.
8. Scroll to the right in the Global Variable Worksheet to the PDD and OPC columns, then left-click once on the header of the PDD column. This should select all the rows, as shown, below:
9. **Right-click** on any individual PDD checkbox and choose **“Properties”** from the pop-up menu.

![Diagram of ControlWave user interface with checkbox for PDD and OPC]

10. In the Properties dialog box, select both the PDD and OPC boxes and click on **[OK]**.

   ![Properties dialog box with checkboxes for PDD and OPC selected]
This should mark all global variables as PDD and OPC.

11. Re-compile the project once again by clicking on **Build ➔ Make**.

12. Choose **File ➔ Save All**.

13. You can now use these variables as you would any other variables in your ControlWave Designer project. When selecting them in ControlWave Designer, you need to choose the ‘VCWAVE_VARIABLES’ group in the global variables worksheet.
Since we want to get a combined total of these two variables, we can use them as input parameters to the ADD function block. The result of adding them together can be stored in the third variable called TOTAL_FLOW, which is an output parameter.

14. Now that the calculation has been created, compile the program as you normally would using the Build ➔ Make command.

15. Now start the Virtual ControlWave program itself by clicking on Online ➔ Virtual ControlWave. (This is the ‘soft’ controller itself.)

16. After successfully compiling the program, call up the Project Control dialog box, as you do when you normally perform a download. If your project has more than one resource, the dialog box may look different than you are used to, because you’ll be required to choose which resource you want to download to, and connect to that resource.

   In this case, you need to select the resource for the Virtual ControlWave. If you only have one resource, the regular Project Control dialog box will appear.

17. Now download your project and initiate a cold start. Remember, we’re not downloading it into a real ControlWave controller, we’re downloading it to a Virtual ControlWave controller running on your PC using the IPC_40 resource, with its special settings.

   NOTE: If you want the downloaded project to start automatically every time you run the Virtual ControlWave, be sure you select the bootproject to be part of the download.

   Once the calculation is running in the Virtual ControlWave, the results of the total flow calculation will be regularly updated within the OpenEnterprise Database. You could trend them, include them on a display, etc.

   To see the current value of the variables you brought in via the Virtual ControlWave Configuration Tool, you can enter ‘Debug’ mode in ControlWave Designer, or you can view them in the Virtual ControlWave Statistics Tool.
You can now close down ControlWave Designer, if desired. The Virtual ControlWave will continue to run and perform calculations on its own.

The Statistics Tool starts automatically when you download the project. To bring it into view, click on the icon, shown at right, in the System Tray at the bottom of your screen.

**Number of Virtual I/O Points**

To the OE Database that are currently configured.

**Maximum Virtual I/O Points**

Allowed under this license. Will display 2000, 5000, or no value. If no value, indicates no restriction other than availability of system resources.
Application Notes

Including the Virtual ControlWave as part of your OpenEnterprise Session

Most OpenEnterprise users will find it convenient to include the Virtual ControlWave as part of their OpenEnterprise Session. This ensures that the Virtual ControlWave is running, and performing calculations, whenever the OpenEnterprise Database is running.

In the Session Manager, choose Add → Task.

Use the [Browse] button to locate pcwin32.exe in your Open BSI MWT folder, then click on [Next>] to move through the various pages of the Session Manager, accepting defaults each time. Finally, click [Finish] and the Virtual ControlWave will now be part of your session.

NOTE: Most users choose to have the Session Manager run the Virtual ControlWave as a critical task, which restarts the Virtual ControlWave automatically following a failure. This is also the default setting. For this to work properly, however, you MUST have downloaded the bootproject to the Virtual ControlWave; otherwise the Virtual ControlWave will have no project to run when restarted after a failure.

NOTE: Since the OPC Server is also required for the Virtual ControlWave to operate, you may want to add a task for it in the Session Manager, if it isn’t configured to run automatically. This would be configured similarly to the way you did for the Virtual ControlWave. The default path for the OPC Server is:

C:\Program Files\BristolBabcock\OpenEnterprise\Bin\BristolOPCServer.exe

Using Lists in Your ControlWave Project to Improve Performance

The very first time an input from the OE Database is used in the program, there can be a slight delay as the OPC server initializes the OPC tag. Using a list in your ControlWave Designer program for your Virtual ControlWave inputs will help your program run better. Initializing the list on Cold start will cause the values of the database signals to be instantly available to your program at run time. When your global Virtual ControlWave variables are included in a list, they are refreshed at start up and in the background as the program runs. There is no pause for initialization the first time a value is requested from the database. See the LISTxxx and DBLOAD sections of the ControlWave Designer ACCOL3 Function Block online help, for more information on working with lists.
Using the Same OE Database Signal as both an Input and an Output

A signal from the Open Enterprise Database may be defined as an input or as an output when using the Virtual ControlWave Configuration Tool, but you may not use the same OPC Tag as both an input and an output.

Sometimes, though, you may have a calculation in which you want to use the same signal as both an input and an output. To accomplish this, one OPC tag can come from a ‘view’ of a table, and another tag can come from the table itself.

For example, “Input” has been selected as the type for this signal, and the IEC1161 name has been changed from the default “vdig_102_value” to “vdig_102_in” to denote that it is mapped as an input. This tag references the ‘digital’ view.

Now, to use the same signal as an output, we need to use a different OPC Tag that points to the same signal. In this case we are referencing the ‘digital_table’, NOT the ‘digital’ view. This ensures that we have two separate OPC tags, even though they are both referencing the same signal in the OE Database.

You will now have 2 different ControlWave Designer variables that are connected to the same OE Database signal. One may be used an input from the OE Database and the other as an output to the OE Database from your ControlWave Designer project.

This same approach may be used for any of the tables and views in the database that contain common signals, for example:

realanalog and nw3000realanalog
nw3000realanalog and nw3000realanalog_table
localrealanalog and realanalog
etc…
**Inputs and the OPC Quality Flag**

When you designate a signal to be an input in the Virtual ControlWave, you have the option of including the OPC Quality Flag. When you save the Configuration, a BOOL variable will be added to your VCW Global Variables for each input that includes the quality flag.

The name of this Quality BOOL will be the input signal’s name with the suffix “_Q”. For example, if the input signal was named vdig_1_in, and we included the OPC Quality Flag for that signal in the Configuration, after saving we would have 2 ControlWave Designer Variables: One will be the Input from the database (vdig_1_in) and the other one will be the BOOL Quality variable (vdig_1_in_Q).

If the quality of the input from the OPC Server is good, the value of the quality BOOL will be FALSE. If the quality of the input is other than good, the value of the quality BOOL will be TRUE.

```
vdig_1_in       quality = Good
vdig_1_in_Q    value  = FALSE
```

-----------------------------------------------

```
vdig_1_in       quality = Bad
vdig_1_in_Q    value  = TRUE
```

**Limitations on the Number of Signals (Points) in the Virtual ControlWave Project**

Although the Virtual ControlWave license allows for 5000 points, this may not achievable for all Data Types. The total PDD memory available in a Control Wave Designer Program is 64 kb. Refer to the chart below to determine the memory requirements for your signal quantities.

**Memory Used by Data Type:**
- BOOL: 1 byte
- INT: 2 bytes
- DINT: 4 bytes
- REAL: 4 bytes
- STRING: 85 bytes

**Things to remember:**
- DATETIME values from the database will be treated as STRING
- INTEGER8 values from the database will be treated as DINT
- When using OPC Quality for an input, an extra BOOL will be assigned, using 1 additional byte.
Appendix A

Creating Local Signals in OpenEnterprise

What is a Local Signal?
Most of the time, we’re concerned with bringing data from RTUs and storing it in the OE
Database. Because those signals originate from remote process controllers, they are referred to as
remote signals, or RTU signals, etc. Sometimes, though, it can be useful to create a signal that
only resides in the OE Database, i.e. a local signal. Local signals are often used to store results
of calculations that come from more than one RTU.

For example, you might have three RTUs that are measuring flow, and you need to have a signal
that reports the total flow from all three RTUs. You can create a calculation in the Calculation
Server or the Virtual ControlWave that adds together the flow from each RTU, and stores it in a
local signal in the OE Database.

Creating a Local Signal Using the SQL Client

1) Start the SQL Client:

   Start ➔ Programs ➔ OpenEnterprise ➔ Database ➔ SQL

2) Enter the following statements in the SQL Client:

   insert into localtablename (name,regionname,devicename) values ('signalname','','');
   commit;

   where localtablename is the name of the table in the database that will hold the
   local signal. Typically, this would be ‘localrealanalog’ or
   ‘localdigital’.

   signalname is the name of the local signal.

   For example:

   insert into localrealanalog (name, accessarea, regionname, devicename)
   values (‘TOTAL_FLOW’, ’ALL’, ‘’, ‘’);
   commit;

   NOTE: We don’t need to enter values for regionname and devicename when creating
   a local signal.
Appendix B

Virtual ControlWave Configuration Text File (VCWCFG.PLC)

When you use the Virtual ControlWave Configuration Tool to add database signals to your Designer project, the tool is actually creating and editing a configuration file called VCWCFG.PLC which resides in the RTU_RESOURCE folder of your ControlWave project.

By default, the path for this file is:

C:\OpenBSI\Projects\ProjectName\C\ControlWave\R\RTU_RESOURCE\VCWCFG.PLC

If necessary, you may create or modify this file manually or programmatically. This is useful when you don’t want to drag and drop every signal into the Configuration Tool window from Database Explore. For example, if you want to add a large number of signals, it could be very time consuming to add them one at a time.

Configuration File Format:

The first line in the file must be:

----- Virtual ControlWave Configuration Tool File -----

Each subsequent line represents one global Virtual ControlWave signal and has the following format. Each field on the line is delineated by a Tab character.

Variable_name   OPC_tag   Quality_flag   Input_Output_flag

where:

Variable_name is the name of the Virtual ControlWave variable in your ControlWave project. For example, vdig_1_in.

OPC_Tag is the text of the OPC Tag in the OPC server, for example: "BristolBabcock.BristolOPCServer"rtrdb1".digital."name:char:vdig_1".value:bool"

Quality_flag will be 0 for Outputs or for Inputs that do not use a quality flag. It will be 1 for Inputs that use the quality flag.

Input_Output_flag will be 1 for an Input or 0 for an Output.
The sample file, below, shows all signals configured as inputs without the quality flag:

![Sample File](image)

**IMPORTANT**

Once the configuration file has been created or modified outside of the Virtual ControlWave Configuration Tool, the Tool must be opened and the configuration must be saved for the changes to be saved to your ControlWave Designer Project.
Virtual ControlWave

The information in this document is subject to change without notice. Every effort has been made to supply complete and accurate information. However, Bristol, Inc. assumes no responsibility for any errors that may appear in this document.

If you have comments or questions regarding this manual, please direct them to your local Bristol sales representative, or direct them to one of the addresses listed at left.

Bristol, Inc. does not guarantee the accuracy, sufficiency or suitability of the software delivered herewith. The Customer shall inspect and test such software and other materials to his/her satisfaction before using them with important data.

There are no warranties, expressed or implied, including those of merchantability and fitness for a particular purpose, concerning the software and other materials delivered herewith.

The Emerson logo is a trade mark and service mark of Emerson Electric Co. Other trademarks or copyrighted products mentioned in this document are for information only, and belong to their respective companies, or trademark holders.

Copyright (c) 2007, Bristol, Inc., 1100 Buckingham St., Watertown, CT 06795. No part of this manual may be reproduced in any form without the express written permission of Bristol, Inc.